$re = '/(\w+?)(?:Local)?$/m';
$str = 'it.foo.burp.ArticleDAOLocal
it.foo.burp.ArticleDAO';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);