re = /(\w+?)(?:Local)?$/m
str = 'it.foo.burp.ArticleDAOLocal
it.foo.burp.ArticleDAO'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end