package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d+[.]\d+|\d+|[*]+|[/]|[+]|[-]|(?:.+[)])`)
var str = `1+2+3*510.11**1*(1+1-2+(1-2))+2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}