Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
r"
^((?!known-to-fail|env_browser).)*$
"
gm
Input 1
1
New
["known-to-fail", "env_ci", "env_local"] ["non-exclusive", "env_browser", "env_local"] ["env_ci"] ["env_ci", "env_local", "known-to-fail"] ["env_ci", "env_local"] [] ""