package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[0-9]{4}\-[0-9]{4}\-[0-9]{4}\-[0-9]{4}$`)
var str = `0000-1111-2222-3333`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}