package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<First_Stop>\.[^\.]+)\.[^\.]+\.(?<Last_Stop>.+)`)
var str = `.Madrid-plane.taxi$comp$uber.domestic$depart `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}