$re = '/(?<First_Stop>\.[^\.]+)\.[^\.]+\.(?<Last_Stop>.+)/m';
$str = '.Madrid-plane.taxi$comp$uber.domestic$depart ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);