const regex = new RegExp('(?P<transaction_date>\\d+/\\d+)\\s*(?P<description>.*?)\\s*(?P<amount>[\\d.,]+)$', 'gm')
const str = `06/07 URBAN TRANSIT CO. SINGAPORE SG 1.38
07/07 MORNING BITES CAFE SINGAPORE SG 4.20
13/07 SUNRISE TOAST HAVEN SINGAPORE SG 3.20`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}