re = /(?P<transaction_date>\d+\/\d+)\s*(?P<description>.*?)\s*(?P<amount>[\d.,]+)$/m
str = '06/07 URBAN TRANSIT CO. SINGAPORE SG 1.38
07/07 MORNING BITES CAFE SINGAPORE SG 4.20
13/07 SUNRISE TOAST HAVEN SINGAPORE SG 3.20'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end