# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b([0-F]+)\b/0$1~0123456789ABCDEF0/g;t' <<< "109"