// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\b([0-F]+)\b").unwrap();
let string = "109";
let substitution = "0$1~0123456789ABCDEF0";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}