# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([a-z])\1/$1$1$1/gmi;t' <<< "too many professionals
would turn into
tooo many professsionals"