const regex = /([a-z])\1/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([a-z])\\1', 'gmi')
const str = `too many professionals
would turn into
tooo many professsionals`;
const subst = `$1$1$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);