use strict;
my $str = 'too many professionals
would turn into
tooo many professsionals';
my $regex = qr/([a-z])\1/mip;
my $subst = '$1$1$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";