re = /([a-z])\1/mi
str = 'too many professionals
would turn into
tooo many professsionals'
subst = '$1$1$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result