package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(?:ctrl|alt)\+\w+`)
var str = `CTRL+a
ALT+B
ctrl+1
alt+3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}