re = /(7[2-9]|80).*um en|abc0123/m
str = '[72-80]% maximum energy shield
abc0123'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end