const regex = /.journal-bg {[^{]*(?<bc>background-color.*;)[^{]*}/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.journal-bg {[^{]*(?<bc>background-color.*;)[^{]*}', '')
const str = `sadf
.journal-bg {
background-color: #112021;
background: #184E3B #154a47;
background: -moz-linear-gradient(top, #154a47 0%, #598238 100%);
background: -webkit-linear-gradient(top, #154a47 0%, #598238 100%);
background: linear-gradient(to bottom, #154a47 0%, #598238 100%);
filter: progid:DXImageTransform.Microsoft.gradient(startColorstr='#154a47', endColorstr='#598238', GradientType=0 );
border-bottom: 3px solid #F7EF8F;
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}