# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(\d+)\r?\n(?!\*{1,}END\*{1,})/$1,/gm;t' <<< "abc
1
2
3
4
5
***END***
abc
6
7
8
9
***END***
abc
10
11
12
***END***"