#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^\/]*\/level\/[^\/]*$"
Local $sString = "foo.bar/level/1A" & @CRLF & _
"foo.bar/level/1A/test" & @CRLF & _
"foo.bar/level/1B" & @CRLF & _
"foo.bar/level/1A/blabl/sdffs" & @CRLF & _
"foo.bar/test"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")