$re = '/(?:\?|&)((?:[^=]+)=(?:[^&]*))/';
$str = 'http://example.org/?foo=bar&baz=boo';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);