// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?<name>[Cc])hresti").unwrap();
let string = "Chrestiens";
let substitution = "${name}hréti";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}