import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^\\s\\d]*\\d\\S*";
final String string = "I made $425\n"
+ "I got mine at 42c. per share\n"
+ "Stocks saw a 12% increase";
final String subst = "NUMBER";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}