# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<!\w)(\(?(\+|00)?48\)?)?[ -]?\d{3}[ -]?\d{3}[ -]?\d{3}(?!\w)"
test_str = ("+48 123 456 789 \n\n"
"123456789\n\n"
"123 456 789 \n\n"
"123-456-789\n\n"
"(+48) 123 456 789\n\n"
"+48123456789\n\n"
"0048123456789\n\n\n"
"Things not to capture: \n\n"
"12 345 67 89\n"
"1234567899876543211\n"
"654564654654654654\n"
"spam \n"
"1231312asdasdf1231231\n"
"123321\n"
"+4863227124")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.