#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m),? *(?P<weekDays>[^\d:\n]+):? *(?P<startTime>[^,\n]+)"
Local $sString = "Tue.-Wed.: 17.45 μεταγλ." & @CRLF & _
"Thur., Wed.: 20.00" & @CRLF & _
"Thur.-Wed.: 18.15/ 20.15 μεταγλ." & @CRLF & _
"Thur.-Wed.: 21.15" & @CRLF & _
"Thur.-Sun., Τρ., Τετ.: 21.10" & @CRLF & _
"Sat., Sun.: 18.10 μεταγλ." & @CRLF & _
"Thur., Fri., Sat., Sun., Tue., Wed. 9 μ.μ." & @CRLF & _
"Wed. 9 μ.μ." & @CRLF & _
"Thur.-Sun., Tue., Wed.: 20.50/ 23.00, Mon. 23.00"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")