using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?={{)(.*?)}}";
string substitution = @"sads";
string input = @"Nemo enim ipsam voluptatem quia {{ voluptas }} labore et {{ dolore }} eum
<a href=""{{iure}}"">reprehenderit</a> qui <a href=""{{ news }}"">in</a> ea.""
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}