use strict;
my $str = 'Nemo enim ipsam voluptatem quia {{ voluptas }} labore et {{ dolore }} eum
<a href="{{iure}}">reprehenderit</a> qui <a href="{{ news }}">in</a> ea."
';
my $regex = qr/(?={{)(.*?)}}/p;
my $subst = 'sads';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";