re = /(?={{)(.*?)}}/
str = 'Nemo enim ipsam voluptatem quia {{ voluptas }} labore et {{ dolore }} eum
<a href="{{iure}}">reprehenderit</a> qui <a href="{{ news }}">in</a> ea."
'
subst = 'sads'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result