const regex = /```(.*)\s*([^]+?.*?[^]+?[^]+?)```/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('```(.*)\\s*([^]+?.*?[^]+?[^]+?)```', 'g')
const str = `\`\`\`markdown
## Hello
This is my new code:
\`\` <-- tutaj powinny być trzy " \` " ale psuje regex.
Tak powinna wyglądać grupa. Mój pomysł na rozwiązanie, to dodanie spacji przez trzema " \` ".
Ale jak to zrobić w regex? :x
Czy da się to jeszcze lepiej zrobić, aby użytkownik mógł pisać kod z wykorzystaniem trzech "\`"?
\`\`
\`\`\``;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}