using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(?:\[(?<text>.*)\])(?:\((?<url>https?\:\/\/.*?)(?:\s\""(?<alt>.*?)\""\)|\)))|(?<text>(?<url>https?\:\/\/\S*)))";
string input = @"http://host.com
some text http://localhost
Some text
[Link Text](https://url.com ""Optionl Alt"")
[Link Text 2](http://url.com ""Optionl Alt 2"")
[Link Text without alt](https://url.com)
dummy link http://dummy.com
https://none.edu asdsf
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}