package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:\d{1,3}(?:,\d{3})+|\d+)(?:\.\d+)?$`)
var str = `10000000
10,000,000
10000000.00`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}