re = /^(?:\d{1,3}(?:,\d{3})+|\d+)(?:\.\d+)?$/m
str = '10000000
10,000,000
10000000.00'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end