# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/tooltipid: \[(.*)\]/tooltipid: ['$1']/gm;t' <<< " coordinateid: [20,54.1],
colorid: [250,0,0],
sizeid: [2000],
tooltipid: [B],"