$re = '/tooltipid: \[(.*)\]/m';
$str = ' coordinateid: [20,54.1],
colorid: [250,0,0],
sizeid: [2000],
tooltipid: [B],';
$subst = "tooltipid: ['$1']";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;