package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\-\..*)`)
var str = `filename.jpeg
filename-.png
file name.doc
file name 3.mp4
file name -.dxg
file.name.mov`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}