import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\-\\..*)";
final String string = "filename.jpeg\n"
+ "filename-.png\n"
+ "file name.doc\n"
+ "file name 3.mp4\n"
+ "file name -.dxg\n"
+ "file.name.mov";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}