const regex = /.*?;(.*?);.*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*?;(.*?);.*', 'g')
const str = `1943;1943: The Battle of Midway (Euro);Final Burn Alpha;;1987;Capcom;Shooter / Flying Vertical;2P sim;270;joystick (8-way);good;1;raster;;;;2`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);