using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\d),(?=\d)";
string substitution = @".";
string input = @"00:00:00,166 --> 00:00:03,999 In this section we will look at";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}