re = /(?:\G(?!^)|Temp\(C\):) \K\d+/
str = '28.6MH/s 27.3MH/s | Temp(C): 64 66 61 64 63 | Fan: 74% 76% 69% 75% 72% | HW: 21 21 21'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end