// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)[0-9A-Z][0-9A-Za-z,;:'"\* ]*[.!?;:]"#).unwrap();
let string = "This is an english sentence tokenizer; it tokenizes correct english sentences.
This can be done in a very short, \"regex\" string.
Incorrect sentence examples be like:
awesome thats so cool!
The text states, \"Super!\".
sys.exit()
(parenthesis)
New headlines!?!?!?
I want ice cream and/or pizza.
Correct sentence examples be like:
Awesome, that's so cool!
The text states, \"Super\"!
0x000F;
S's's's's.
New headlines!
I want ice cream and or pizza.
I hate regex's \"catastrophic backtracking\" it's literally fake.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}