import Foundation
let pattern = #"[0-9A-Z][0-9A-Za-z,;:'"\* ]*[.!?;:]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
This is an english sentence tokenizer; it tokenizes correct english sentences.
This can be done in a very short, "regex" string.
Incorrect sentence examples be like:
awesome thats so cool!
The text states, "Super!".
sys.exit()
(parenthesis)
New headlines!?!?!?
I want ice cream and/or pizza.
Correct sentence examples be like:
Awesome, that's so cool!
The text states, "Super"!
0x000F;
S's's's's.
New headlines!
I want ice cream and or pizza.
I hate regex's "catastrophic backtracking" it's literally fake.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)