#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[0-9]{1,5}"
Local $sString = "6004" & @CRLF & _
"281" & @CRLF & _
"2812" & @CRLF & _
"89112" & @CRLF & _
"23" & @CRLF & _
"02891" & @CRLF & _
"7821" & @CRLF & _
"28199" & @CRLF & _
"96822" & @CRLF & _
"56615" & @CRLF & _
"44261" & @CRLF & _
"60928" & @CRLF & _
"72912" & @CRLF & _
"527" & @CRLF & _
"910" & @CRLF & _
"0011" & @CRLF & _
"11111"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")