$re = '/^(?<time>[^\[]+)\[(?<loglevel>[^\]]+)\]\s*request="(?<request>[[:xdigit:]]+)"\s*component="(?<component>[^"]+)"[[:punct:]]?[[:blank:]]*(?<message>.*)$/m';
$str = 'Sun, 28 Jun 2020 03:41:30 +0200 [WARNING] request="387b66f92c909" component="TYPO3.CMS.Frontend.Controller.TypoScriptFrontendController": $TSFE->set_no_cache() was triggered. Reason: config.no_cache is set. Caching is disabled!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);