$re = '/((?:\d{1,2}:)?\d{2}:\d{2}\.\d{2,3})\h*-->\h*((?1))\R(.+)/m';
$str = '908
59:44.940 --> 59:48.410
THE MICROPHONE BUTTON AND
909
59:48.420 --> 1:00:06.450
THERE SHOULD BE AN OPTION TO UNMUTE DO
910
1:00:06.460 --> 1:00:09.870
YOU SEE A MICROPHONE ICON ANYWHERE ON YOUR TEAMS
911
1:00:10.280 --> 1:00:19.420
PLATFORM I\'M
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);