$re = '/\w+|\s+/m';
$str = 'Arnold Arn Besrf Degy
Asd Fgt Tghy Uigh Hjju
Arnol #$ Df';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);