use strict;
my $str = ' [1] 2 3 4 5 6 7 8 9 ';
my $regex = qr/(\s{2})(\[)([a-zA_Z0-9]*)(\])(\s{2})([a-zA_Z0-9]*)(\s{3})/p;
my $subst = '$7$3$1$2$6$4$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";