import Foundation
let pattern = #"(\s{2})(\[)([a-zA_Z0-9]*)(\])(\s{2})([a-zA_Z0-9]*)(\s{3})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #" [1] 2 3 4 5 6 7 8 9 "#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$7$3$1$2$6$4$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)