import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(src=\\x22(https:\\/\\/[a-z]+.com\\/mp3s\\/[0-9]+\\?id=[0-9]+)\\x22)[\\s\\S]*";
final String string = "src=\"https://example.com/mp3s/2342344?id=24362456\"src=\"https://example.com/mp3s/2342344?id=24362456\"\n"
+ "src=\"https://example.com/mp3s/2342344?id=24362456\" src=\"https://example.com/mp3s/2342344?id=24362456\"src=\"https://example.com/mp3s/2342344?id=24362456\"";
final String subst = "\\2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}