// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\S+\s+\S+\s+\w+\.\w+\s+(switch\d\d)\s").unwrap();
let string = "2018-07-19 08:00:00 Local6.Notice switch01 ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}