import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "object\\/(custom|standard)\\/(.*)(?:\\/(typea|typeb))(?:\\/(.*))?";
final String string = "Objects/Custom Objects/Applicant/Recruitment Pipeline/Buttons, Links, and Actions/Accept\n\n"
+ "object/custom/name1/name2\n"
+ "object/custom/name1/name2/typea\n"
+ "object/custom/name1/name2/typea/item\n\n"
+ "object/standard/name1/name2\n"
+ "object/standard/name1/name2/typeb\n"
+ "object/standard/name1/name2/typeb/item";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}